x
Wyn Enterprise 3.6 is now available! See what’s new Wyn Enterprise 3.6 is now available! See what’s new Wyn Enterprise 3.6!

Wyn Enterprise: Installing on RedHat (RHEL)

You can install Wyn Enterprise on RHEL using yum command.

  1. To install .NET Runtime 2.1, run the following commands.

    sudo rpm -Uvh https://packages.microsoft.com/config/rhel/7/packages-microsoft-prod.rpm
    sudo yum install aspnetcore-runtime-2.1
    
  2. (this step is optional) To install PostgreSQL, run the following command.

    sudo yum install postgresql-server 
    
  3. (this step is optional) To configure PostgreSQL, run the following command.

    sudo bash -c "echo 'postgres' > /var/lib/pgsql/pwf"
    sudo mkdir -p /var/lib/pgsql/data
    sudo chown -R postgres /var/lib/pgsql/data
    sudo -u postgres initdb -D /var/lib/pgsql/data -A md5 -E utf8 --pwfile=/var/lib/pgsql/pwf
    sudo systemctl enable postgresql
    
  4. (this step is optional) To start PostgreSQL, run the following command.

    sudo systemctl start postgresql
    
  5. To configure YUM REPO information, run the following command.

    sudo bash -c 'echo "[wynrepo]
    name=Wyn Enterprise
    baseurl=https://gecfartifacts.blob.core.windows.net/repos/yumrepo/wyn/3.6/en/
    enabled=1
    gpgcheck=0" > /etc/yum.repos.d/wyn.repo'
    
  6. To install Wyn Enterprise, run the following command.

    sudo yum install wyn-enterprise
    
  7. To configure Wyn Enterprise service, run the following command.

    sudo bash /opt/Wyn/Monitor/config.sh
    
  8. To configure Firewall, run the following command.

    sudo firewall-cmd --zone=public --add-port=51980/tcp --permanent
    sudo firewall-cmd --reload
    

More Commands

  • To install a specific version.

    sudo yum install wyn-enterprise-{version}
    
  • To update the version.

    sudo yum update wyn-enterprise
    
  • To uninstall.

    sudo yum erase wyn-enterprise
    
  • To show the package information of installed Wyn Enterprise.

    yum info wyn-enterprise
    
  • To force downgrade package.

    sudo yum downgrade wyn-enterprise-{version}